Processing of deposit submissions (content registration) delayed
Incident Report for Crossref
Resolved
Pausing our HA proxy work and dedicating additional resources to processing your submissions has fixed the backlog of pending submissions in the queue. All submissions in the admin tool deposit queue - doi.crossref.org - were submitted today; users should no longer be experiencing content registration delays.
Posted Feb 22, 2021 - 18:43 UTC
Identified
This issue has been identified and a fix is being implemented. Our ongoing HA proxy work coupled with higher (than normal) volumes of submissions over the last few weeks has contributed to a backlog of pending submissions in the admin tool deposit queue - doi.crossref.org. This has caused delays for content registration for members throughout Crossref. We have paused our HA proxy work and dedicated additional resources to processing your submissions, our highest priority at the moment.
Posted Feb 17, 2021 - 16:31 UTC
Update
We are continuing to investigate this issue.
Posted Feb 16, 2021 - 21:30 UTC
Investigating
We continue to see high volumes of submissions to the admin tool deposit queue - doi.crossref.org - and our recent HA proxy work (https://0-status-crossref-org.brum.beds.ac.uk/incidents/j9325lfr82sf) seems to be contributing to delayed processing as well. We have dedicated additional threads to work through the current backlog, while we investigate the underlying issues.
Posted Feb 16, 2021 - 21:30 UTC
This incident affected: Content Registration (Admin tool, Test admin tool) and Beta (Metadata Manager).